VNP Challenge using GRE Protocol

Task to Perform

Create VPN between both LAN using GRE Protocol

Do not Advertise Private networks into OSPF

Both LANs should communicate with each other.

Note: Once you are done do comment below so that we can put you into the selected candidate and if you are selected you will get a very good gift from Tech Guru Manjit Sir Side.

You May be Interested Into

OSPF LAB CHALLENGE FOR REACHABILITY

9 COMMENTS

  1. I accepted this challenge sir….also I complete this lab
    .
    .
    .
    First I create a VPN tunnel ISP5 to ISP1..then we assign same series of private ip adds to connected a VPN…like in ISP1 have a IP is 192.168.30.1 and ISP5 have a IP is 192.168.30.2..

    1] we create a tunnel form ISP1 we assign the IP 192.168.30.1…..then we decide a source and destination tunnel point form ISP1 source point is Fa0/0…and destination point is Fa0/0…(destination IP should be a public IP) and then we encapsulate the tunnel with IPV4.

    same router configuration perform on ISP5 router….(source and destination are the same)

    but after that ISP5 Lan & ISP1 Lan they are not communicate with each other…
    so that we configure this private IP through RIP configuration…we can advertise the private Network IPs…this all we configure in both the ISP router(ISP1 and ISP5)

    then we ping the IPs like …(form ISP1 ping 192.168.20.1)…
    100% replay rate is coming..

    link of the LAB–https://drive.google.com/drive/folders/1vgPHCHapmgMrQSzOSDvwT7wNZK5vgDMV?usp=sharing

  2. commands on Router ISP1
    ISP1(config)#int tunnel 1
    ISP1(config-if)#tunnel mode gre ip
    ISP1(config-if)#tunnel source f0/0
    ISP1(config-if)#tunnel destination 5.0.0.2
    ISP1(config-if)#ip address 200.20.10.10 255.255.255.0
    ISP1(config)#ip route 0.0.0.0 0.0.0.0 5.0.0.2

    commands on Router ISP5
    ISP5(config)#int tunnel 1
    ISP5(config-if)#tunnel mode gre ip
    ISP5(config-if)#tunnel source f0/0
    ISP5(config-if)#tunnel destination 2.0.0.1
    ISP5(config-if)#ip address 200.20.30.30 255.255.255.0
    ISP5(config-if)#ip route 0.0.0.0 0.0.0.0 2.0.0.1

  3. Router ISP1—->

    ISP1(config)#int tunnel 0
    ISP1(config-if)#ip address 192.168.30.1 255.255.255.0
    ISP1(config-if)#tunnel source f0/0
    ISP1(config-if)#tunnel destination 5.0.0.2
    ISP1(config-if)#tunnel mode gre ip

    Router ISP5—–>

    ISP5(config)#int tunnel 0
    ISP5(config-if)#ip address 192.168.30.2 255.255.255.0
    ISP5(config-if)#tunnel source f0/0
    ISP5(config-if)#tunnel destination 2.0.0.1
    ISP5(config-if)#tunnel mode gre ip

  4. Sir I accepted this challenge
    First of all in step 1
    ▪︎STEP 1 :– we have to create VPN tunnel from ISP 1 to ISP 5 so let’s start.
    IN ISP 1 CREATE VPN TUNNEL
    ISP1# configure terminal
    ISP1(config)# interface tunnel 0
    ISP1(config)# ip address 192.168.30.1 255.255.255.0
    ISP1(config)# no shutdown
    ISP1(config)# tunnel source f0/0
    ISP1(config)# tunnel destination 5.0.0.2
    ISP1(config)# tunnel mode gre ip
    ISP1(config)# end

    ▪︎STEP 2 :– we have to create VPN in ISP 5
    ISP5# configure terminal
    ISP5(config)# interface tunnel 0
    ISP5(config)# ip address 192.168.30.2 255.255.255.0
    ISP5(config)# no shutdown
    ISP5(config)# tunnel source f0/0
    ISP5(config)# tunnel destination 2.0.0.2
    ISP5(config)# tunnel mode gre ip
    ISP5(config)# end

    Now how we can show tunnel was created so in Step 3 for show tunnel 0

    ▪︎STEP 3 :– ISP1# show ip interface brief
    You can show tunnel with the help of this command

    :– ping from 192.168.30.1 to 192.168.30.2 successfully
    But one problem is here you can’t able to ping between
    private network of ISP 1 OR ISP 5 (192.168.10.0 OR
    192.168.20.0)

    So in Step 4 we have to perform any routing technology to give the information in router so..

    ▪︎STEP 4 :– perform routing in ISP1 and ISP5 router
    ISP1# configure terminal
    ISP1(config)# ip routing
    ISP1(config)# router ospf 100
    ISP1(config)# router I’d 1.1.1.1
    ISP1(config)# network 192.168.10.0 0.0.0.255 area 0
    ISP1(config)# network 192.168.30.0 0.0.0.255 area 0

    ▪︎STEP 5 :– Same configuration in ISP 5 router
    ISP5# configure terminal
    ISP5(config)# ip routing
    ISP5(config)# router ospf 100
    ISP5(config)# router I’d 2.2.2.2
    ISP5(config)# network 192.168.20.0 0.0.0.255 area 0
    ISP5(config)# network 192.168.30.0 0.0.0.255 area 0

    ●Now this neghbourship is created with the tunnel 0

    ● AND NOW PING FROM ISP1 PRIVATE NETWORK TO ISP5 PRIVATE NETWORK

    ISP1# ping 192.168.20.1
    Success rate is 100%

    So we can communicate securely from ISP1 PRIVATE NETWORKS TO ISP5 PRIVATE NETWORKS .

    THANKS FOR THIS GREAT LAB SIR
    👍👍

  5. Goto the Isp2 router first
    command-
    ISP2(config)# interface Tunnel0
    ISP2(config-if)# tunnel source 2.0.0.2
    ISP2(config-if)# tunnel destination 5.0.0.2
    exit
    ISP2 (Config)# ip route 192.168.20.0 255.255.255.0 Tunnel0
    now back to ISP5
    ISP5(config)# interface Tunnel0
    ISP5(config-if)# tunnel source 5.0.0.2
    ISP5(config-if)# tunnel destination 2.0.0.2
    exit
    ISP5 (Config) ip route 192.168.10.0 255.255.255.0 Tunnel0

    to verify the tunnel…just check BOTH SIDE
    sh run int Tunnel0 ,status and protocol must be UP UP to communicate through tunnel
    and LAN will ping successfully both router

    Thank you

  6. goto router ISP2 – command
    ISP2(config)# interface Tunnel0
    ISP2(config-if)#tunnel mode GRE ipv4
    ISP2(config-if)# tunnel source 2.0.0.2
    ISP2(config-if)# tunnel destination 5.0.0.2
    exit
    ISP2(Config)# ip route 192.168.10.0 255.255.255.0 Tunnel0

    now goto router ISP5 command
    ISP5(config)# interface Tunnel0
    ISP2(config-if)#tunnel mode GRE ipv4
    ISP5(config-if)# tunnel source 5.0.0.2
    ISP5(config-if)# tunnel destination 2.0.0.2
    exit
    ISP5 (Config) ip route 192.168.20.0 255.255.255.0 Tunnel0

    to verify the tunnel…just checke
    sh run int Tunnel0 ,status and protocol must be UP UP to communicate through tunnel

    Thank you…

LEAVE A REPLY

Please enter your comment!
Please enter your name here